User Tools

Site Tools


inkscape_for_lasering

Inkscape for laser cutting

Inkscape is a free and open source vector drawing package. It's useful for making vector drawings for laser cutting and can generate files that the laser cutter software can import.

Various lab members/friends have experience with using Inkscape, so you can safely ask questions about using it on our mailing list or at open nights.

You can download Inkscape for Linux/MacOS/Windows here, it's also packaged for most Linux distros (install it via your distros package manager).

Drawing for lasering

There are plenty of guides and such for learning how to use Inkscape, but here are some hints specifically for laser cutting.

The laser cutter works in millimetres but Inkscape defaults to pixels. Create a new file and then switch to mm by opening the document properties from File → Document Properties. Change the default units to mm.

You may also want to create a page that's the approximate size of our laser cutter bed, which is 300x600mm.
(click image to embiggen)

Exporting for the laser cutter software

Before exporting, make sure to convert all objects to paths. The laser cutter software only imports paths, not Inkscape objects, so if you don't convert then you might lose objecty things like rounded boxes and text. This is easy to fix: select all of your drawing (Edit → Select all, or [Ctrl]+A) and then run Path → Object to Path. It may appear that nothing has happened, but in fact your objects are now paths and you're ready to export to the laser cutter! (click image to embiggen)
The laser cutter does a reasonable job of importing DXF files, so that's our preferred format for importing. Inkscape can write DXF files, just go to File → Save As…, or File → Save a Copy… and select Desktop Cutting Plotter (AutoCAD DXF R14)(*.dxf) from the list of filetypes (it's near the bottom)

You'll get another window of export options, make sure the Base unit setting is mm, Use ROBO-Master type of spline output is unticked (this can cause problems with curves) and then hit OK.
( click image to embiggen)

Exporting for the laser cutter software using a script

As an alternative, this script (svg2dxf) can be used:

#!/bin/bash

inkscape --export-text-to-path -f $1 -E /tmp/tmp.eps ; pstoedit -f "dxf_s:-polyaslines -mm" /tmp/tmp.eps ${1/\.svg/\.dxf}

You'll need inkscape and pstoedit installed.

inkscape_for_lasering.txt · Last modified: 2017-09-24 21:50 by adq